Back
Maintenance

Deployment of easter update

Completed 15 Apr at 12:30am CEST.

Minecraft Network
Completed

Posted 15 Apr at 12:30am CEST.
Started

Today we are going to deploy a little easter update and some bugfixes

Posted 15 Apr at 12:00am CEST.