Back
Maintenance

Bugfix & Mini-Update deployment

Completed 25 May at 12:30am CEST.

Minecraft Network
Completed

Posted 25 May at 12:30am CEST.
Started

Today we are going to deploy the latest bugfixes and a mini update of one of our developers

Posted 25 May at 12:00am CEST.